OS4 DepotLogo by Marko 
(anonymous IP: 54.160.245.121,1139) 
 HomeRecentStatsSearchSubmitUploadsMirrorsContactInfoDisclaimerConfigAdmin
 Menu

 Features
   Crashlogs
   Bug tracker
   Locale browser
 
 Categories

   o Audio (328)
   o Datatype (47)
   o Demo (180)
   o Development (529)
   o Document (21)
   o Driver (87)
   o Emulation (141)
   o Game (852)
   o Graphics (457)
   o Library (88)
   o Network (200)
   o Office (56)
   o Utility (804)
   o Video (60)

Total files: 3850

Full index file. Download
Recent index file. Download




 Links

  Amigans.net
  OpenAmiga
  Aminet
  IntuitionBase


Support the site


 File comments for:  Video » Convert » ffmpeg.lha

FFmpeg

Description: Video and audio converter
Download: ffmpeg.lha
Version: 3.4
Date: 25 Nov 17
Category: video/convert
FileID: 10392
RSS Feed url: http://os4depot.net/modules/comments/rssfeed.php?file=video/convert/ffmpeg.lha

[Back to readme page]   [Add Comment]   [Refresh page]

Comment by: MickJT (118.211.111.216)At: 27 Nov 2017, 07:37File version: 3.4
Correction to the readme. The solution for altivec binaries wasn't linker libs from 4.2.4, but using binutils 2.18 which has different internal linker scripts.
 
 
Comment by: ghh (89.177.235.56)At: 30 Jul 2016, 21:17File version: 3.1.1
Concat works (filter and protocol). Thank you!
 
 
Comment by: MickJT (118.211.73.30)At: 11 Jul 2016, 18:38File version: 3.0.2
It's an issue with a patch for is_dos_path. It'll be fixed in the next upload.
 
 
Comment by: MickJT (118.211.73.30)At: 11 Jul 2016, 18:10File version: 3.0.2
This is a different issue unrelated to the use (or non-use) of -safe 0. I'll look into it.
 
 
Comment by: Jurassicc (31.50.64.210)At: 10 Jul 2016, 17:06File version: 3.0.2
Many Thanks for the Tip
thumbsup:
 
 
Comment by: k (73.252.224.45)At: 10 Jul 2016, 02:46File version: 3.0.2
Put -safe 0 before the -i command and it will work again.
 
 
Comment by: Jurassicc (31.50.64.210)At: 09 Jul 2016, 22:56File version: 3.0.2
concat nolonger works

eg:-

ffmpeg -i "concat:VTS_01_1.VOB|VTS_01_2.VOB|VTS_01_3.VOB"

ask for volume concat:
 
 
Comment by: MickJT (124.169.231.119)At: 17 Apr 2016, 09:35File version: 2.8.5
I don't know if that's possible. As far as I know, OS4.x itself is 32bit.
 
 
Comment by: J. Aarbakk (85.165.230.223)At: 16 Apr 2016, 15:41File version: 2.8.5
Thanks for making this nice tool available for the Amiga!

Question: Would it be possible to provide binaries that is optimized for 64 bit CPU's?
 
 
Comment by: J.T.Kirk (79.131.48.197)At: 18 Jan 2016, 13:06File version: 2.8.5
"updating"... that was obvious...
 
 
Comment by: J.T.Kirk (79.131.48.197)At: 18 Jan 2016, 13:06File version: 2.8.5
Thank you for upading this excellent program; appreciated.
 
 
Comment by: ghh (78.102.145.97)At: 06 Apr 2015, 22:44File version: 2.6.1
Thank you! I love this program.
 
 
Comment by: MickJT (124.169.172.153)At: 17 Sep 2014, 01:21File version: 2.1.4
Paths starting with / will be translated by libunix. I'd rather not link it without that, because I find it useful. Adding ".." before the slash will work around it.

I need a command line example for filter_complex. I have sent you a private message elsewhere.
 
 
Comment by: Hypex (202.173.193.240)At: 16 Sep 2014, 18:13File version: 2.1.4
Does the filter_complex option work? If I specify it by itself it says I am missing arguments. But if I give arguments it says the option is not recognised! :-?

Also it doesn't accept Amiga path names. If it starts with a slash it thinks it is a volume.

Errors below:
ffmpeg_ppc: missing argument for option 'filter_complex'
Unrecognized option 'filter_complex'
 
 
Comment by: MickJT (124.171.138.30)At: 09 Aug 2013, 21:07File version: 2.0
If you have a volume called data: or even file:, that is going to confuse ffmpeg because those have special meanings. As you've noticed, changing the case is a workaround. Same goes with having a volume called http:
 
 
Comment by: Thematic (88.113.184.161)At: 07 Aug 2013, 23:25File version: 2.0
The solution was correct but the cause was actually the exact string 'data:' (read or write, write error message is "Impossible to open the 'data' protocol for writing").
 
 
Comment by: Thematic (88.113.184.161)At: 07 Aug 2013, 23:06File version: 2.0
Maybe this will save somebody's hair... the Amiga volume name (first part of a path) has to have a capital first letter or it seems to not get recognized as a volume name. The error message is "No ',' delimiter in URI".

I first thought it's just being case sensitive but that isn't the... situation.
 
 
Comment by: MickJT (124.171.148.28)At: 08 Mar 2013, 19:09File version: 1.1.3
@K-L

I probably should have said the Unpack script is in the FFmpeg directory. One thing I hadn't noticed was that you need to set the executable flag on the files created by xdelta3-decoder, with C:Protect or DOpus. Seeing as I already have the "unpacked" binaries anyway, I wasn't aware of that until now.
 
 
Comment by: K-L (89.92.161.176)At: 08 Mar 2013, 17:52File version: 1.1.3
Ok, it is written ON OS4Depot :-)

Sorry I did not read so far :-(
 
 
Comment by: K-L (89.92.161.176)At: 08 Mar 2013, 17:47File version: 1.1.3
Thanks BUT how are we supposed to create the Altivec version ??? I had to google about xdelta-decoder3 to find something on Aminet with a doc and even with this I could not manage to create anything.

I think that even a really small AmigaOS documentation woud have been useful.

BTW, why don't your create the Altivec version and then release it on OIS4Depot ?
 
 
Comment by: samo79 (93.144.75.144)At: 08 Mar 2013, 17:06File version: 1.1.3
@MickJT

Fantastic, thanks a lot Mick !
 
 
Comment by: MickJT (124.171.148.28)At: 08 Mar 2013, 16:18File version: 1.1.3
Thanks to Mikael "SMF" Rantanen for testing the Altivec build for me (1.1.3).
 
 
Comment by: MickJT (124.171.67.161)At: 13 Aug 2010, 13:21File version: 0.6
Make a thread about it on one of the forums. No such problem here. Need more info too, like what your input file is, exactly how you're using ffmpeggui. Post on the forums.
 
 
Comment by: DaveyW (203.109.168.245)At: 13 Aug 2010, 08:21File version: 0.6
@ktadd
No, I'm not talking about the buffer under-run report. The resulting file is somehow corrupt. If you create a file with mp3 audio, and then use "Input File Info" (on FFMpegGUI) to examine the file, the duration is reported as 00:00:00.00 and the bitrate is enormous (in the test I just ran off, I created with with 2040, but info reports it as "bitrate: 2147483 kb/s". DVPlayer & MPlayer can play the file, but can't seek.
 
 
Comment by: ktadd (192.25.142.225)At: 09 Aug 2010, 20:30File version: 0.6
Opps, sorry. The last comment was meant for when using with ffmpegGUI.
Still the ffmpeg reported error about buffer issues when encoding to mp3 can be safely ignored.
 
 
Comment by: ktadd (192.25.142.225)At: 09 Aug 2010, 20:27File version: 0.6
@DavyW
Read the requester that is displayed at the end when encoding to mp3 audio. It's a bug with the library used to encode mp3. It can safely be ignored as pointed out in the requester. Unless of course your getting a different requester? Post to Amigans or Amigaworld if that's the case.
 
 
Comment by: DaveyW (203.109.175.230)At: 06 Aug 2010, 21:01File version: 0.6
Still seem to be having problems encoding mp3 audio
 
 
Comment by: MickJT (124.171.69.129)At: 08 Jul 2010, 14:26File version: 0.6
sinisrus, a new version of the GUI will be available very soon. Don't worry.
 
 
Comment by: sinisrus (86.70.206.233)At: 08 Jul 2010, 13:07File version: 0.6
ffmpeggui crash with ffmpeg 0.6 :-(
 
 
Comment by: afxgroup (80.183.222.154)At: 15 Aug 2006, 13:20File version: cvs
ffmpeg is really simply to compile using the original sources from main page.
but you need a working gg installed or (better..) a cross compiler.
if you need the sources just send a mail
 
 
Comment by: anonymous (68.98.237.196)At: 15 Aug 2006, 06:28File version: cvs
I though you'd have the source included. The real nice thing is that you can use
the ffmpeg.lib and add video i/o to you apps.

Any plans to release the source ? or the lib ?
 
 
Comment by: Lio (213.103.209.210)At: 13 Aug 2006, 19:38File version: cvs
I thought all codecs were already implemented hence the size of the binary.
no pb and thx for this port.
 
 
Comment by: afxgroup (80.183.222.154)At: 13 Aug 2006, 17:52File version: cvs
i'll try to add more codecs, but atm i'm working on mencoder (and mplayer) to..
 
 
Comment by: Lio (213.103.201.41)At: 13 Aug 2006, 17:23File version: cvs
some codecs play well -> thx
could be a multipurpose tool (audio player, video player, for web browser)
ogg is ok but FLAC support is missing.
here is the output :
11.RAM Disk:FFmpeg/Altivec> ffplay_altivec dha:TheRock-BOF.flac
dha:TheRock-BOF.flac: could not find codec parameters
 
 
Comment by: spot (85.226.98.50)At: 13 Aug 2006, 13:07File version: cvs
top notch warez!
 
 

Copyright (c) 2004-2017 by Björn Hagström All Rights Reserved
Amiga OS and its logos are registered trademarks of Hyperion Entertainment