OS4 DepotLogo by Alkaron 
(anonymous IP: 52.205.167.104,1800) 
 HomeRecentStatsSearchSubmitUploadsMirrorsContactInfoDisclaimerConfigAdmin
 Menu

 Features
   Crashlogs
   Bug tracker
   Locale browser
 

 Categories

   o Audio (333)
   o Datatype (50)
   o Demo (196)
   o Development (567)
   o Document (21)
   o Driver (96)
   o Emulation (144)
   o Game (938)
   o Graphics (486)
   o Library (105)
   o Network (222)
   o Office (61)
   o Utility (869)
   o Video (65)

Total files: 4153

Full index file
Recent index file

 Links

  Amigans.net
  OpenAmiga
  Aminet
  IntuitionBase


Support the site


 Readme for:  Audio » Play » wildmidi.lha

WildMIDI

Description: A simple software midi player
Download: wildmidi.lha       (TIPS: Use the right click menu if your browser takes you back here all the time)
Size: 41Mb
Version: 0.4.4
Date: 25 Mar 2021
Author: Mindwerks
Submitter: Raziel
Email: raziel_nosgoth/web de
Homepage: http://www.mindwerks.net/projects/wildmidi
Category: audio/play
Replaces: audio/play/wildmidi.lha
License: GPL
Distribute: yes
Min OS Version: 4.1
FileID: 11609
 
Comments: 0
Snapshots: 0
Videos: 0
Downloads: 51  (Current version)
146  (Accumulated)
Votes: 1 (0/0)  (30 days/7 days)

Show comments Show snapshots Show videos Show content Show crashlogs Replace file 
WildMIDI is a simple software midi player which has a core softsynth
library that can be use with other applications.

The WildMIDI library uses Gravis Ultrasound patch files to convert MIDI
files into audio which is then passed back to the calling application.
The library API is designed so that it is easy to include WildMIDI into
applications that wish to include MIDI file playback.

CHANGELOG

0.4.4
* Fixed integer overflow in midi parser sample count calculation
 (bug #200).
* Fixed 8 bit ping pong GUS patch loaders (bug #207).
* Fixed wrong variable use in reverb code (bug #210).
* Reset block status of tty after playback (bug #211).
* Fixed broken file name handling for 'save as midi' command during
  playback.
* Clamp MUS volume commands (PR #226).
* CMake project improvements (bugs: #214, #216, #217, #218) - cmake
  version 3.1 or newer is now required.

Copyright © 2004-2021 by Björn Hagström All Rights Reserved