OS4 DepotLogo by Alkaron 
(anonymous IP: 3.80.85.76,1234) 
 HomeRecentStatsSearchSubmitUploadsMirrorsContactInfoDisclaimerConfigAdmin
 Menu

 Features
   Crashlogs
   Bug tracker
   Locale browser
 

 Categories

   o Audio (329)
   o Datatype (47)
   o Demo (186)
   o Development (534)
   o Document (21)
   o Driver (88)
   o Emulation (142)
   o Game (860)
   o Graphics (464)
   o Library (94)
   o Network (202)
   o Office (57)
   o Utility (815)
   o Video (61)

Total files: 3900

Full index file
Recent index file

 Links

  Amigans.net
  OpenAmiga
  Aminet
  IntuitionBase


Support the site


 Readme for:  Graphics » Edit » gimp-src.lha

Gimp-src

Description: Sources of Gimp 2.6.11 for AmiCygnix
Download: gimp-src.lha       (TIPS: Use the right click menu if your browser takes you back here all the time)
Size: 5Mb
Version: 2.6.11r2
Date: 22 Jun 2013
Author: Spencer Kimball, Peter Mattis (http://www.gimp.org) - OS4 port by Edgar Schwan
Submitter: Edgar Schwan
Email: eds at rz-online de
Homepage: http://www.schwan-clan.de
Requirements: AmigaOS 4.1, SDK V53.20, amicygnix-x11-src.lha, amicygnix-base-src.lha V1.3
Category: graphics/edit
Replaces: graphics/edit/gimp-src.lha
License: Other
Distribute: yes
Min OS Version: 4.1
FileID: 8003
 
Comments: 0
Snapshots: 0
Videos: 0
Downloads: 68  (Current version)
181  (Accumulated)
Votes: 0 (0/0)  (30 days/7 days)

Show comments Show snapshots Show videos Show content Show crashlogs Replace file 
   This is a source collection of the packages used in the second release
  of Gimp 2.6.11 for AmiCygnix.

  All included packages are provided as diff files. You need to download the
  original archives and patch them with the corresponding diff file. In the
  following summary all packages are listed together with a link, where you
  can download the original archive.

  In every package you can find an amigados scripts called
  "amicygnix-configure.bat". Use the script to configure the project. I have
  included the makefiles and config files created by configure. Some of them
  are modified by hand. You CAN'T compile the packages with these files, you
  must reconfigure the package.

  IMPORTANT: Please copy your projects to "Cygnix:Development" or
             "Cygnix:CygnixPPC/local/src" and not to "Cygnix:CygnixPPC/src"
             and use the prefix "/Cygnix/CygnixPPC/local" for configure!


Included packages:
------------------

  Package name                   Download link
  ------------                   -------------

  aalib-1.4rc4.tar.gz            http://switch.dl.sourceforge.net/project/
                                 aa-project/aa-lib/1.4rc4/aalib-1.4rc4.tar.gz

  babl-0.0.22.tar.bz2            http://artfiles.org/gimp.org/babl/0.0/
                                 babl-0.0.22.tar.bz2

  gegl-0.0.22.tar.bz2            http://artfiles.org/gimp.org/gegl/0.0/
                                 gegl-0.0.22.tar.bz2

  gimp-2.6.11.tar.bz2            http://artfiles.org/gimp.org/gimp/v2.6/
                                 gimp-2.6.11.tar.bz2

  goocanvas-1.0.0.tar.gz         http://ftp.gnome.org/pub/GNOME/sources/
                                 goocanvas/1.0/goocanvas-1.0.0.tar.gz

  Imaging-1.1.6.tar.gz           http://effbot.org/media/downloads/
                                 Imaging-1.1.6.tar.gz

  lcms-1.19.tar.gz               http://netcologne.dl.sourceforge.net/project/
                                 lcms/lcms/1.19/lcms-1.19.tar.gz

  libart_lgpl-2.3.21.tar.gz      http://ftp.acc.umu.se/pub/GNOME/sources/
                                 libart_lgpl/2.3/libart_lgpl-2.3.21.tar.gz

  libexif-0.6.20.tar.gz          http://switch.dl.sourceforge.net/project/
                                 libexif/libexif/0.6.20/libexif-0.6.20.tar.gz

  libgsf-1.14.21.tar.gz          http://ftp.acc.umu.se/pub/GNOME/sources/
                                 libgsf/1.14/libgsf-1.14.21.tar.gz

  libwmf-0.2.8.4.tar.gz          http://switch.dl.sourceforge.net/project/
                                 wvware/libwmf/0.2.8.4/libwmf-0.2.8.4.t

  ncurses-5.5.tar.gz             http://ftp.gnu.org/pub/gnu/ncurses/
                                 ncurses-5.5.tar.gz

  poppler-0.5.4.tar.gz           http://poppler.freedesktop.org/
                                 poppler-0.5.4.tar.gz

  poppler-data-0.2.0.tar.gz      http://poppler.freedesktop.org/
                                 poppler-data-0.2.0.tar.gz

  pycairo-1.8.4.tar.gz           http://cairographics.org/releases/
                                 pycairo-1.8.4.tar.gz

  pygobject-2.28.6.tar.bz2       http://ftp.gnome.org/pub/GNOME/sources/
                                 pygobject/2.28/pygobject-2.28.6.tar.bz2

  pygoocanvas-0.14.1.tar.gz      http://ftp.gnome.org/pub/GNOME/sources/
                                 pygoocanvas/0.14/pygoocanvas-0.14.1.tar.gz

  pygtk-2.24.0.tar.gz            http://napoleon.acc.umu.se/pub/GNOME/
                                 sources/pygtk/2.24/pygtk-2.24.0.tar.gz

  Python-2.7.2.tar.bz2           http://www.python.org/ftp/python/2.7.2/
                                 Python-2.7.2.tar.bz2

  readline-4.3.tar.gz            http://www.artfiles.org/gnu.org/readline/
                                 readline-4.3.tar.gz

  sqlite-3.3.13.tar.gz           http://www.sqlite.org/sqlite-3.3.13.tar.gz


How to patch:
-------------

  Example: Patch the gimp-2.6.11 package:

  * Download the original archive and unpack the archive to (for example) "ram:"
    Afterwards a directory called "gimp-2.6.11" is located in "ram:"

  * Copy the corresponding patch file "gimp-2.6.11.diff" to "ram:".

  * Open a shell and cd into "ram:".

  * Type into the shell:

    "patch -p1 -u -dgimp-2.6.11 --verbose <gimp-2.6.11.diff"

    and press return.

    The patch command is included in the AmigaOS4 SDK.


File Version Size Date OS Dls Readme
gimp-beautify-src.lha2.6.114Mb16 Apr 20134.1103¤ Gimp-beautify-src - Sources of beautify for Gimp 2.6.11 for AmiCygnix
gimp-beautify.lha2.6.1155Mb16 Apr 20134.1312¤ Gimp-beautify - Gimp 2.6.11 beautify plug-in for AmiCygnix
gimp-color-plugins.lha2.6.1197Mb06 Apr 20134.1257¤ Gimp-color-plugins - Gimp 2.6.11 color plug-ins for AmiCygnix
gimp-filters-1.lha2.6.11121Mb03 Apr 20134.1291¤ Gimp-filters-1 - Gimp 2.6.11 filter plug-ins vol. 1 for AmiCygnix
gimp-filters-2.lha2.6.11115Mb03 Apr 20134.1288¤ Gimp-filters-2 - Gimp 2.6.11 filter plug-ins vol. 2 for AmiCygnix
gimp-filters-3.lha2.6.11116Mb04 Apr 20134.1282¤ Gimp-filters-3 - Gimp 2.6.11 filter plug-ins vol. 3 for AmiCygnix
gimp-filters-4.lha2.6.11104Mb05 Apr 20134.1261¤ Gimp-filters-4 - Gimp 2.6.11 filter plug-ins vol. 4 for AmiCygnix
gimp-loaders-1.lha2.6.1180Mb01 Apr 20134.1288¤ Gimp-loaders-1 - Gimp 2.6.11 loaders vol. 1 for AmiCygnix
gimp-loaders-2.lha2.6.11137Mb02 Apr 20134.1288¤ Gimp-loaders-2 - Gimp 2.6.11 loaders vol. 2 for AmiCygnix
gimp-plugin-pack-src.lha2.6.111Mb16 Apr 20134.191¤ Gimp-plugin-pack-src - Sources of the plug-in pack for Gimp 2.6.11
gimp-plugin-pack.lha2.6.1178Mb16 Apr 20134.1310¤ Gimp-plugin-pack - Gimp 2.6.11 plug-in pack for AmiCygnix
gimp.lha2.6.11r2143Mb22 Jun 20134.1560¤ Gimp - Gimp 2.6.11 for AmiCygnix
Copyright (c) 2004-2018 by Björn Hagström All Rights Reserved