OS4 DepotLogo by Nickman 
(anonymous IP: 107.21.187.131) 
 HomeRecentStatsSearchSubmitUploadsMirrorsContactInfoDisclaimerConfigAdmin
 Menu

 Features
   Crashlogs
   Bug tracker
   Locale browser
 
 Categories

   o Audio (321)
   o Datatype (47)
   o Demo (176)
   o Development (485)
   o Document (19)
   o Driver (81)
   o Emulation (130)
   o Game (765)
   o Graphics (418)
   o Library (65)
   o Network (185)
   o Office (49)
      o Cad (2)
      o Database (9)
      o Dtp (0)
      o Misc (10)
      o Presentation (4)
      o Spreadsheet (4)
      o Wordprocessing (20)
   o Utility (724)
   o Video (56)

Total files: 3521

Full index file. Download
Recent index file. Download




 Links

  Amigans.net
  OpenAmiga
  Aminet
  UtilityBase
  IntuitionBase
  AmigaBounty


Support the site


 Readme for:  Office » Wordprocessing » abiword-src.lha

Abiword-src

Description: Sources of the AbiWord package
Download: abiword-src.lha       (TIPS: Use the right click menu if your browser takes you back here all the time)
Size: 7Mb
Version: 2.8.6
Date: 05 Jan 13
Author: Various - OS4 port by Edgar Schwan
Submitter: Edgar Schwan
Email: eds at rz-online de
Homepage: http://www.schwan-clan.de
Requirements: AmigaOS 4.1 SDK V53.20, amicygnix-x11-src.lha, amicygnix-base-src.lha
Category: office/wordprocessing
Replaces: office/wordprocessing/abiword-src.lha
License: Other
Distribute: yes
Min OS Version: 4.1
FileID: 7632
 
Comments: 0  [View]
Snapshots: 0  [View]
Downloads: 20  (Current version)
103  (Accumulated)

Show content Show crashlogs Replace file 
  This is a source collection of the packages used in the AbiWord package.

  All included packages are provided as diff files. You need to download the
  original archives and patch them with the corresponding diff file. In the
  following summary all packages are listed together with a link, where I've
  downloaded the original archives.

  In every package you can find an AmigaDOS script called
  "amicygnix-configure.bat". Use this script to configure the package.
  I've included the makefiles and config files created by configure. Some of
  them are modified by hand. You CAN'T compile the packages with these files.
  You must reconfigure the package.

  IMPORTANT: Please copy your projects to "Cygnix:Development" or
             "Cygnix:CygnixPPC/local/src" and not to "Cygnix:CygnixPPC/src"
             and use the prefix "/Cygnix/CygnixPPC/local" for configure!


Included packages:
------------------

  Package name                   Download link
  ------------                   -------------

  abiword-2.8.6.tar.gz           http://www.abisource.com/downloads/abiword/
                                 2.8.6/source/abiword-2.8.6.tar.gz

  abiword-docs-2.8.6.tar.gz      http://www.abisource.com/downloads/abiword/
                                 2.8.6/source/abiword-docs-2.8.6.tar.gz

  aiksaurus-1.2.1.tar.gz         http://mesh.dl.sourceforge.net/sourceforge/
                                 aiksaurus/aiksaurus-1.2.1.tar.gz

  aspell-0.60.5.tar.gz           http://ftp.gnu.org/pub/gnu

  enchant-1.3.0.tar.gz           http://www.abisource.com/downloads/enchant/
                                 1.3.0/enchant-1.3.0.tar.gz

  eps-1.5.tar.gz                 http://www.inter7.com/eps/eps-1.5.tar.gz

  fribidi-0.10.4.tar.gz          http://fribidi.org/download/
                                 fribidi-0.10.4.tar.gz

  glpk-4.47.tar.gz               http://ftp.gnu.org/gnu/glpk/glpk-4.47.tar.gz


  gnumeric-1.10.17.tar.bz2       http://ftp.acc.umu.se/pub/GNOME/sources/
                                 gnumeric/1.10/gnumeric-1.10.17.tar.bz2

  goffice-0.8.17.tar.bz2         http://ftp.acc.umu.se/pub/GNOME/sources/
                                 goffice/0.8/goffice-0.8.17.tar.bz2

  libart_lgpl-2.3.21.tar.gz      http://ftp.acc.umu.se/pub/GNOME/sources/
                                 libart_lgpl/2.3/libart_lgpl-2.3.21.tar.gz

  libgsf-1.14.21.tar.gz          http://ftp.acc.umu.se/pub/GNOME/sources/
                                 libgsf/1.14/libgsf-1.14.21.tar.gz

  libwpd-0.9.2.tar.gz            http://mesh.dl.sourceforge.net/project/libwpd/
                                 libwpd/libwpd-0.9.2/libwpd-0.9.2.tar.gz

  libwps-0.2.2.tar.bz2           http://mesh.dl.sourceforge.net/project/libwps/
                                 libwps/libwps-0.2.2/libwps-0.2.2.tar.bz2

  link-grammar_4.2.2.tar.gz      http://ftp.debian.org/debian/pool/main/l/
                                 link-grammar/link-grammar_4.2.2.orig.t

  ots-0.5.0.tar.gz               http://mesh.dl.sourceforge.net/sourceforge/
                                 libots/ots-0.5.0.tar.gz

  readline-4.3.tar.gz            http://ftp.gnu.org/pub/gnu

  wv-1.2.9.tar.gz                http://www.abisource.com/downloads/wv/1.2.9/
                                 wv-1.2.9.tar.gz


How to patch:
-------------

  Example: Patch the abiword-2.8.6 package:

  * Download the original archive and unpack the archive to (for example)
    "ram:". Afterwards a directory called "abiword-2.8.6" is located in "ram:".

  * Copy the corresponding patch file "abiword-2.8.6.diff" to "ram:".

  * Open a shell and cd into "ram:".

  * Type into the shell:

    "patch -p1 -u -dabiword-2.8.6 --verbose <abiword-2.8.6.diff"

    and press return.

    The patch command is included in the AmigaOS4 SDK.


File Version Size Date OS Dls Readme
abiword.lha2.8.6r257Mb17 Mar 134.1400¤ Abiword - AbiWord 2.8.6 for AmiCygnix
Copyright (c) 2004-2014 by Björn Hagström All Rights Reserved
Amiga OS and its logos are registered trademarks of Hyperion Entertainment