OS4 DepotLogo by Alkaron 
(anonymous IP: 54.167.144.4,80) 
 HomeRecentStatsSearchSubmitUploadsMirrorsContactInfoDisclaimerConfigAdmin
 Menu

 Features
   Crashlogs
   Bug tracker
   Locale browser
 
 Categories

   o Audio (322)
      o Convert (31)
      o Edit (25)
      o Misc (74)
      o Play (133)
         o Tunenet (71)
      o Record (3)
      o Rip (32)
      o Tracker (24)
   o Datatype (47)
   o Demo (176)
   o Development (487)
   o Document (19)
   o Driver (82)
   o Emulation (131)
   o Game (786)
   o Graphics (422)
   o Library (74)
   o Network (185)
   o Office (50)
   o Utility (735)
   o Video (56)

Total files: 3572

Full index file. Download
Recent index file. Download




 Links

  Amigans.net
  OpenAmiga
  Aminet
  UtilityBase
  IntuitionBase
  AmigaBounty


Support the site


 File comments for:  Audio » Play » xmp.lha

Xmp

Description: XMP multi-module player + TuneNet plugin
Download: xmp.lha
Version: 4.1(3.9.0)
Date: 15 Mar 13
Category: audio/play
FileID: 7795
RSS Feed url: http://os4depot.net/modules/comments/rssfeed.php?file=audio/play/xmp.lha

[Back to readme page]   [Add Comment]   [Refresh page]

Comment by: salass00 (94.101.5.193)At: 31 Jan 2012, 15:09File version: 3.2.0
@Thematic

Maybe it is just programmed to stop when it receives input from the shell (stdin)?
 
 
Comment by: Thematic (88.112.226.248)At: 20 Jan 2012, 22:43File version: 3.2.0
Strange behaviour (different from what I'm used to on AmigaOS): if I start it _without run_ in shell, and enter another xmp command line before the first one returns, the first one is interrupted. Some sort of detachment maybe?
 
 
Comment by: salass00 (94.101.5.193)At: 03 May 2011, 07:55File version: 3.2.0
No, just replacement AHI-Handler. AHI-Handler is just a handler (a simpler type of filesystem) that implements the AUDIO: interface that the Amiga port of xmp uses. The interface is somewhat similar to OSS on linux which makes rewriting linux audio code that uses OSS audio system to use AUDIO: usually very simple.

The AHI-Handler replacement I was testing was supposed to be a total rewrite of the original AHI one to be more portable and have some new features. I'll probably get back to working on it again at some point.
 
 
Comment by: spot (83.248.105.187)At: 02 May 2011, 23:00File version: 3.2.0
replacement ahi driver?
 
 
Comment by: salass00 (91.150.31.84)At: 01 May 2011, 11:01File version: 3.2.0
Tested and it works fine on my Sam440EP. I can't check now but it's possible that I had simply forgot to put back the original AHI-Handler in L: after having tested a replacement AHI-Handler that I was working on some time ago and this was causing the problems with xmp.
 
 
Comment by: Thematic (85.156.234.245)At: 28 Apr 2011, 19:03File version: 3.2.0
What happens when AHI is occupied anyway by another program? Here it runs through the module at 100x rate without error (message), ostensibly decoding it.
 
 
Comment by: salass00 (94.101.5.193)At: 28 Apr 2011, 08:13File version: 3.2.0
Something appears to be broken in this version because I can't get to play anything. It just prints the initial file info stuff and then stops (I can see that there is some CPU usage but no audio is produced and the current position in the CLI isn't being updated).

Also this program could really use a stack cookie.
 
 
Comment by: spot (85.228.116.147)At: 27 Nov 2007, 13:02File version: 2.5.0-pre5
xeron, that's very true. i just read the midi part, my tired eyes skipped the
mmd1 part.
 
 
Comment by: xeron (90.201.184.153)At: 26 Nov 2007, 18:54File version: 2.5.0-pre5
mmd1 is med not midi
 
 
Comment by: anonymous (85.228.116.147)At: 26 Nov 2007, 15:14File version: 2.5.0-pre5
"Several MMD1 files play at half the intended tempo"
Don't use this player for MIDI files.
Use Curty's midi plugin for TuneNet instead, it does a better job by far!
http://www.os4depot.net/share/audio/play/tunenet/tunemidi_plug.lha

The MIDI bug reports should be sent to the author of XMP.
 
 
Comment by: Chris Young (80.6.31.96)At: 26 Nov 2007, 08:31File version: 2.5.0-pre5
I'm working on making this into a TuneNet plug-in, but bear with me... it might
have to wait until 2.6.
 
 
Comment by: Thematic (85.156.227.236)At: 26 Nov 2007, 05:54File version: 2.5.0-pre5
Several MMD1 files play at half the intended tempo, despite that xmp
"Estimated time" seems to be correct. Example:
http://aminet.net/mods/tranc/lns27_goaEp1.lha
 
 
Comment by: Spot (85.228.116.147)At: 26 Nov 2007, 04:31File version: 2.5.0-pre5
What's wrong with the MED support?
 
 
Comment by: Thematic (85.156.227.236)At: 26 Nov 2007, 04:09File version: 2.5.0-pre5
Don't hold your breath about MED playback. But some of my favourite DBM were
listenable, that's great!
 
 
Comment by: Spot / Up Rough (85.228.116.147)At: 26 Nov 2007, 03:53File version: 2.5.0-pre5
If it crashes, try raising the stack. I'll fix this once i know how much stack
it uses.
 
 

Copyright (c) 2004-2014 by Björn Hagström All Rights Reserved
Amiga OS and its logos are registered trademarks of Hyperion Entertainment