OS4 DepotLogo by Browallia 
(anonymous IP: 18.206.187.81,1488) 
 HomeRecentStatsSearchSubmitUploadsMirrorsContactInfoDisclaimerConfigAdmin
 Menu

 Features
   Crashlogs
   Bug tracker
   Locale browser
 

 Categories

   o Audio (330)
   o Datatype (49)
   o Demo (188)
   o Development (553)
   o Document (21)
   o Driver (89)
   o Emulation (143)
   o Game (887)
   o Graphics (474)
   o Library (103)
   o Network (212)
   o Office (57)
   o Utility (835)
   o Video (62)

Total files: 4003

Full index file
Recent index file

 Links

  Amigans.net
  OpenAmiga
  Aminet
  IntuitionBase


Support the site


 File comments for:  Development » Library » Graphics » libpng.lha

libpng

Description: Lib for handling PNG files
Download: libpng.lha
Version: 1.6.37
Date: 02 Aug 2019
Category: development/library/graphics
FileID: 10972
RSS Feed url: http://os4depot.net/modules/comments/rssfeed.php?file=development/library/graphics/libpng.lha

[Back to readme page]   [Add Comment]   [Refresh page]

Comment by: LiveForIt (81.167.17.251)At: 18 Aug 2014, 22:26File version: 1.6.8
Sorry I spoke too soon, problems was caused by mismatch of header files and libs and having different libraries in SDK:clib then in SDK:local/clib and so on. Deleted every thing and reinstalled it and it worked.
 
 
Comment by: MickJT (118.211.66.219)At: 17 Aug 2014, 17:24File version: 1.6.8
Hi. It's libz.lha on OS4Depot.
 
 
Comment by: LiveForIt (81.167.17.251)At: 17 Aug 2014, 12:17File version: 1.6.8
Can't compile anything with this version.
need a newer zlib where do I find it?

http://stackoverflow.com/questions/19738464/pngfix-c2151-undefined-reference-to-inflatereset2
 
 
Comment by: Robert (89.72.186.94)At: 31 Jul 2011, 11:17File version: 1.5.2
@Raziel

It seems that libpng needs libz which contains compression algorithms for PNG images.
 
 
Comment by: Raziel (84.145.10.228)At: 19 Nov 2010, 22:49File version: 1.4.4
With this so i get a warning on linking a formerly problem free program

ld: warning: libz.so.1, needed by /SDK/local/newlib/lib/libpng.so, not found (try using -rpath or -rpath-link)

Why is that and what can i do about it?
The program itself starts up fine, but i'm always careful when new warnings pops out...
 
 

Copyright © 2004-2020 by Björn Hagström All Rights Reserved