OS4 DepotLogo by Nickman 
(anonymous IP: 3.226.245.48,1534) 
 HomeRecentStatsSearchSubmitUploadsMirrorsContactInfoDisclaimerConfigAdmin
 Menu

 Features
   Crashlogs
   Bug tracker
   Locale browser
 

 Categories

   o Audio (331)
   o Datatype (49)
   o Demo (188)
   o Development (554)
   o Document (21)
   o Driver (90)
   o Emulation (143)
   o Game (899)
   o Graphics (476)
   o Library (103)
   o Network (212)
   o Office (60)
   o Utility (837)
   o Video (64)

Total files: 4027

Full index file
Recent index file

 Links

  Amigans.net
  OpenAmiga
  Aminet
  IntuitionBase


Support the site


 File comments for:  Utility » Workbench » prefscenter.lha

Prefs Center

Description: Launch prefs programs from a GUI
Download: prefscenter.lha
Version: 1.8
Date: 22 Feb 2017
Category: utility/workbench
FileID: 10169
RSS Feed url: http://os4depot.net/modules/comments/rssfeed.php?file=utility/workbench/prefscenter.lha

[Back to readme page]   [Add Comment]   [Refresh page]

Comment by: Tuomas (77.86.211.251)At: 07 Mar 2017, 19:16File version: 1.8
Did you put the catalog file into a correct directory ? Language stuff should work like it works always on AmigaOS really.

Do you have an account in amigans.net or amigaworld.net ?
 
 
Comment by: Tarzin (86.72.2.109)At: 04 Mar 2017, 14:20File version: 1.8
I've translated PrefsCenter in French but it's impossible to use the french catalog (PrefsCenter remains in english).
How can I use my translation ? (I saw there was an installation tool for english en Finnish)
Thanks for advance
 
 
Comment by: cha05e90 (194.114.62.159)At: 14 Nov 2016, 07:57File version: 1.7
Yes, I have that freezes, too.
Regardless which machine (Pegasos II, Sam440ep, X1000). I suspect the drawer.gadget as well.
 
 
Comment by: Tuomas (77.86.211.251)At: 13 Nov 2016, 22:14File version: 1.7
@user
I have suspected something like that myself. I don't know if the problem is in the drawer.gadget of PrefsCenter. But such problem is something which have to get fixed some day. Could you make a test disabling BACKDROP tooltype if it makes it better ? Sorry for inconvinience.
 
 
Comment by: user (95.245.233.19)At: 12 Nov 2016, 11:28File version: 1.7
It makes my X1000 totally unstable.
After I launch the prefs program the X1000 freezes in a matter of 30 seconds.
 
 
Comment by: cha05e90 (194.114.62.123)At: 04 Apr 2016, 08:13File version: 1.6
In contrast to the old version the new version only shows the icon/prefs program name in the user tab, *not* the user defined "Label". The predefined tabs seem to work ok (means: showing your predefined labels instead of the original icon/program name).
 
 
Comment by: Severin (84.51.187.249)At: 03 Apr 2016, 00:57File version: 1.6
> The font of the rastport of the window is used which should be the system font set in Fonts prefs. I cannot understand how it could be different.
The software tab is using either drawer text font or screen font (both set to the same on my system) and the other tabs are using system default font.

> Yes, sys:mui/mui is used.
That's wrong, MUI:MUI should always be used, it was designed to be installed anywhere by the user not just sys:

> If AISS is not installed so something that doesn't exist cannot be used obviously.
AISS is installed. turn it on in prefs and save and it's disabled in tooltypes with brackets probably because it's not found.
Again like MUI prefs, AISS images should be acessed through TBImages: not sys:prefs/presets/tbimages that you're using (confirmed with snoopy). NEVER hardcode a path unless you are totally certain everyone uses it eg. sys:prefs is fine but anything that is assigned should always use the assign. This includes C, Libs, Fonts, MUI, locale, TBImages etc.

> Explain word "shudder" ?
The icons are drawn then they are shifted to the right a little and redrawn.
 
 
Comment by: Author (77.86.211.251)At: 03 Apr 2016, 00:40File version: 1.6
If anything is missing from AmigaOS complain to Hyperion-Entertainment.
 
 
Comment by: Author (77.86.211.251)At: 03 Apr 2016, 00:37File version: 1.6
>"low contrast red text"
The default system palette and pens are used.
 
 
Comment by: Author (77.86.211.251)At: 03 Apr 2016, 00:26File version: 1.6
>"Different font used"
The font of the rastport of the window is used which should be the system font set in Fonts prefs. I cannot understand how it could be different.

>"Text is truncated"
That's the selected design. Also AmigaOS doesn't have a word wrapper library to use.

>"sys:mui/mui"
Yes, sys:mui/mui is used.

>"USE_AISS is on by default in the icon tooltypes but there are no images"
If AISS is not installed so something that doesn't exist cannot be used obviously.

>"In simple mode when switching tabs the icons 'shudder'"
Explain word "shudder" ?
 
 
Comment by: Author (77.86.211.251)At: 03 Apr 2016, 00:04File version: 1.6
In any case of problems just keep using the old version which is included in the package.
 
 
Comment by: Severin (84.51.187.249)At: 02 Apr 2016, 13:02File version: 1.6
A few comments about the latest version...

Different font used for text in the 2nd and 3rd tabs (not tried the 4th yet).

Icon max size is ignored.

Window size is not calculated to adjust to the specified cell size.

Text is truncated if it doesn't fit in a cell instead of being wrappaed.

Visually the old one looks better and is easier to read, boring gray background in new one, low contrast red text for category titles, No I'm not going to alter GUI prefs just to make prefs center readable and mess up every other program.

MUI prefs does not work here, no icon, can't click on the area. hardcoded to sys:/mui/mui instead of mui:mui maybe?

USE_AISS is on by default in the icon tooltypes but there are no images, it shows it as off in prefs. I turned it on in the prefs and saved. It disabled it in the icon tooltypes.

Window fade in/out gone or broken?

MODE tooltype doesn't seem to do anything.

Switching to simple display causes the scrollbar to shrink making it look like there's about 20 pages to scroll through but in reality there's one line of icons, when the scroller is dragged to the bottom the text under the bottom line of icons cut off.

In simple mode when switching tabs the icons 'shudder'.

 
 
Comment by: Edward Teach (2.84.87.126)At: 02 Apr 2016, 00:43File version: 1.5
We are all poor Amigans my friend...
 
 
Comment by: Author (77.86.211.251)At: 01 Apr 2016, 21:01File version: 1.5
DON'T CALL PEOPLE POOR !!!
 
 
Comment by: Author (77.86.211.251)At: 01 Apr 2016, 21:00File version: 1.5
Check version 1.6.
 
 
Comment by: Edward Teach (2.84.87.126)At: 01 Apr 2016, 18:57File version: 1.5
Sorry, but is this new version ugly than the previous one or is it me? Also it reacts slower than the previous version and the catalog files are out of date. Author didn't even bother to contact translators of the previous version in order to update their catalogs. Poor...
 
 
Comment by: Srtest (79.178.202.183)At: 01 Apr 2016, 13:33File version: 1.5
I can't change settings it gives me a DSI followed by ISI.

When you add something to user preferences once, then delete that entry, then try again to add anything - nothing shows up.
 
 
Comment by: Reth (194.11.254.132)At: 27 Apr 2011, 14:02File version: 1.3
Good thing!

I first recognized sth. like this in one of the latest MOS-Releases and was impressed.
Maybe this one here can get some of the ideas (regarding alignment and sorting) from the MOS counterpart (see here for example: http://www.amiga-magazin.de/magazin/a09-08/mos2/bild1.jpg)?
 
 
Comment by: Tuomas (84.248.40.19)At: 06 Apr 2011, 20:01File version: 1.3
@djrikki
Thanks ! It's uploaded to OpenAmiga and they have my permission.
 
 
Comment by: Tuomas (84.248.40.19)At: 06 Apr 2011, 20:00File version: 1.3
>"I cannot see the Add and Remove application buttons"
They were moved to the last tab/page. Screen grabs are from older 1.1 version. I'm going to upload new screen shots soon.
 
 
Comment by: djrikki (81.104.215.132)At: 06 Apr 2011, 19:27File version: 1.3
PS. I cannot see the Add and Remove application buttons as shown in the submitted screenshots.
 
 
Comment by: djrikki (81.104.215.132)At: 06 Apr 2011, 19:24File version: 1.3
Just installed this excellent application, does exactly what it says on the tin! I highly recommend Hyperion consider this for exclusion in next OS distribution; with permission from Tuomas of course!
 
 
Comment by: Tuomas (84.248.40.19)At: 05 Nov 2010, 17:06File version: 1.3
Shouldn't 16bit screens have alpha channel too ? OS bug ?
 
 
Comment by: Amigo1 (93.197.139.64)At: 05 Nov 2010, 15:33File version: 1.3
mmh.. if memory serves well, the icons where aligned on the very first version (or was it an alpha?).
Anyway, the small program is great! :-)

Comment by: Tuomas (84.248.40.19) At: 03 Nov 2010, 12:29 File version: 1.3
Quote: "would it be possible to align the icons to a grid?"
I've tried but it wasn't possible.

Quote:"it looks a bit scattered"
Yes, it does.
 
 
Comment by: kas1e (78.36.154.30)At: 04 Nov 2010, 19:44File version: 1.3
Same black borders for me on 16bit screen. Older versions was fine.
 
 
Comment by: Severin (83.67.70.55)At: 04 Nov 2010, 19:35File version: 1.3
@che05e90 & Toumas

I use a 16 bit workbench (1680x1050), switching to 32 bit solves the problem. I don't know where the bug is that causes the problem is though.
 
 
Comment by: cha05e90 (84.134.75.118)At: 04 Nov 2010, 04:50File version: 1.3
Strange. I have the same bitmap.image 53.6 class (OS4.1u2). No problems here - @Severin: What screen mode/depth do you have on Workbench?
 
 
Comment by: Tuomas (84.248.40.19)At: 03 Nov 2010, 21:46File version: 1.3
@Severin
Do you have any ideas what could be wrong ?
 
 
Comment by: Severin (83.67.70.55)At: 03 Nov 2010, 18:21File version: 1.3
@Tuomas
I have the latest beta OS4.1u2, with a newer bitmap.image than yours.
 
 
Comment by: Tuomas (84.248.40.19)At: 03 Nov 2010, 17:33File version: 1.3
@Severin
Do you have AmigaOS 4.1 Update2 ? If you have then we have to compare our system settings to find out why it works here but not on your system. If you don't maybe I have to put the old code back using info.datatype as fallback option and change requirements in the readme. Version of BitMap Image class on my system is: bitmap.image 53.6 (29.9.09).
 
 
Comment by: Tuomas (84.248.40.19)At: 03 Nov 2010, 17:29File version: 1.3
Quote: "would it be possible to align the icons to a grid?"
I've tried but it wasn't possible.

Quote:"it looks a bit scattered"
Yes, it does.
 
 
Comment by: amigo1 (93.197.139.180)At: 03 Nov 2010, 17:10File version: 1.3
would it be possible to align the icons to a grid? it looks a bit scattered IMHO :-)
 
 
Comment by: Trifide (95.237.234.250)At: 03 Nov 2010, 15:46File version: 1.3
@ cha05e90
Downloaded and installed the png.iconmodule.
Work very fine, thank you very much! Powericons removed and trashed! :-)
 
 
Comment by: cha05e90 (194.114.62.72)At: 03 Nov 2010, 14:16File version: 1.3
Please uninstall PowerIcons - it's a hack. Install the png.iconmodule (here at os4depot).
 
 
Comment by: Trifide (79.50.237.101)At: 03 Nov 2010, 13:10File version: 1.3
@ cha05e90
On my OS4.1 I installed the powericons patch, and the prefscenter not show this icons, but empty box! why?
 
 
Comment by: cha05e90 (194.114.62.72)At: 03 Nov 2010, 07:42File version: 1.3
...for what do you need PowerIconsPatch???
 
 
Comment by: Trifide (79.41.236.192)At: 03 Nov 2010, 06:58File version: 1.3
In this new release not show icons in powericons patch. :(
 
 
Comment by: Severin (83.67.70.55)At: 02 Nov 2010, 21:40File version: 1.3
The new version has ugly black borders round the icons. Snapshot here:
http://www.am1ga.net/Grab023.jpg
 
 
Comment by: gregthecanuck (96.48.247.159)At: 21 Oct 2010, 03:25File version: 1.2
Very nice program.

Overall layout suggestion: Too many boxes! Many programs are guilty of this and it makes a simple window way too cluttered/busy.

1. Remove the boxes around each group of items.
...A simple horizontal line between each group should be enough.

2. Remove the box around the add/remove buttons

3. Remove the box around the add/remove/close buttons.

Just some tweaks to a great idea. Thanks.

 
 
Comment by: kas1e (78.36.133.12)At: 17 Oct 2010, 16:06File version: 1.2
@Tuomas
New version (1.2) rokz. That fade in/out effect looks very nasty too, and introducing of classic "menu" by right mouse button are good idea too. Mouse wheel also works for fast moving over the tabs :)

If you dont mind, there is few ideas:

-- enable/disable of fade in/out effect (just for better configurability) by tooltypes/gui
-- add ability for user, to configure where place his icons, spliting it on "areas" and so on
-- maybe ability to rename text-info in the system panels (just for better configurability as well) ?
-- just a madness idea - maybe give that "default" look to the user at the first run, but give ability to change/remove/add/regroup every icons in every tabs ?

Imho as Orgin point you need to add that project to OpenAmiga, so Hyperion will add it to the next releases of OS, as one more default icon to default AmiDock.

Btw, right now put prefscenter icon on my AmiDock, and looks liki i will use it only like this now.

Thanks for, its indeed nasty program which should be in os4 already.
 
 
Comment by: cha05e90 (84.134.33.33)At: 15 Oct 2010, 21:18File version: 1.1
@Tuomas
Oh dear, you're right - I wasn't aware, that there's the possibilty to add keyboard shortcuts to AmiDock stuff.
 
 
Comment by: orginAt: 14 Oct 2010, 05:25File version: 1.1
Perhaps you'd be interested to submit this to OpenAmiga.org?
 
 
Comment by: Tuomas (84.248.40.19)At: 13 Oct 2010, 21:18File version: 1.1
@cha05e90
Quote: "- would be nice if PrefsCenter could be a commodity, which leads to request two:
- while it can be started from WBStartup as an commodity it would be perfect if there would be the usual CX_POPUP=NO option possible AND the *enabled* docky icon. So you can start it at startup and have the prefs accessible through a AmiDock docky icon "
As a second thought. It doesn't have to be that way. Put its icon into one of your AmiDock panels and give it a keyboard shortcut in AmiDock prefs. It doesn't have to be a commodity at all.
 
 
Comment by: djrikki (81.104.215.132)At: 11 Oct 2010, 20:10File version: 1.1
Now this is what I am talking about. Starting to look real professional... if everything works as intended I would suggest doing what you can to try and push to get this included in the OS or recognised in AmiUpdate. When I get the new Amiga this is the kind of thing I wanna see from day one.
 
 
Comment by: netrot (93.218.121.14)At: 09 Oct 2010, 01:28File version: 1.1
Nice, very easy to use thx :)
 
 
Comment by: Tuomas (84.248.40.19)At: 08 Oct 2010, 17:48File version: 1.1
@cha05e90
I was thinking that already but didn't implement it yet. ;-)
 
 
Comment by: cha05e90 (84.134.28.3)At: 08 Oct 2010, 17:02File version: 1.1
It's getting better with every release, thanks! Here's a feature request:
- would be nice if PrefsCenter could be a commodity, which leads to request two:
- while it can be started from WBStartup as an commodity it would be perfect if there would be the usual CX_POPUP=NO option possible AND the *enabled* docky icon. So you can start it at startup and have the prefs accessible through a AmiDock docky icon
 
 
Comment by: Tuomas (84.248.40.19)At: 07 Oct 2010, 16:38File version: 1.1
Quote: "editing everything from the main gui"
Maybe some day. It's some work always.
 
 
Comment by: kas1e (95.54.89.58)At: 07 Oct 2010, 11:18File version: 1.1
[quote]
Enable ENABLE_P96_PREFS tooltype !
[/quote]
Yep, bu imho for such kind of program will be cool to have editing everything from the main gui. Like user just run it, and setup as he want all of this.
 
 
Comment by: Tuomas (84.248.40.19)At: 07 Oct 2010, 09:56File version: 1.1
Quote: "For example i want to add P96setup to Peripherals/Video, but looks like i cant ?"
Enable ENABLE_P96_PREFS tooltype !

Quote: "Sadly that i cant remove/add/move icons in the main tabs (but still i have buttons remove/add for them) and can only add/remove in user tabs. "
I was making experiments to make it possible to add user stuff to any groups and pages. I tried to put Add and Remove buttons back to last page but I had made such changes in the code it wasn't that simple any more. I wanted to release this version now anyway.
 
 
Comment by: kas1e (78.36.139.155)At: 07 Oct 2010, 07:31File version: 1.1
New version nice !

Sadly that i cant remove/add/move icons in the main tabs (but still i have buttons remove/add for them) and can only add/remove in user tabs.

For example i want to add P96setup to Peripherals/Video, but looks like i cant ?

Anyway good that it have updated , much better to use this, in compare with all the time going to system:prefs and found right icon.

 
 
Comment by: Tuomas (84.248.40.19)At: 19 Sep 2010, 19:14File version: 1.0
You need info.datatype installed to make icons visible. (I hope info.datatype/similar functionality will be official part of the AmigaOS someday.)
 
 
Comment by: ggw (66.90.154.31)At: 08 Sep 2010, 23:15File version: 1.0
I'm with djrikki. Needs graphics
 
 
Comment by: djrikki (81.104.215.132)At: 05 Sep 2010, 11:17File version: 1.0
Any chance you can populate this program with Mason Icons as opposed to text? If so your on to a winner, at the moment it doesn't look very appealing.
 
 
Comment by: Severin (83.67.70.55)At: 25 Nov 2009, 00:00File version: 1.0
Yeah, I agree it needs to be more configurable with a 4th tab for user prefs as well as being able to change the default entries. I think the real program name should be used instead of having it in brackets, displayed in a larger font and a smaller font for the description (maybe user configurable in a tooltype) or maybe put the description in a help bubble.
 
 
Comment by: cha05e90 (84.134.95.206)At: 21 Nov 2009, 20:16File version: 1.0
Nice one. Although the layout is sometimes a littlebit "flaky". Perfect would be a the possibility to add "other" preferences into the Network, Hardware etc. sections with their own description (i.e. I would like to add third party prefs like "Netprinter Prefs" to the printer section...)
 
 

Copyright © 2004-2020 by Björn Hagström All Rights Reserved