OS4 DepotLogo by Nickman 
(anonymous IP: 35.171.146.16,1359) 
 HomeRecentStatsSearchSubmitUploadsMirrorsContactInfoDisclaimerConfigAdmin
 Menu

 Features
   Crashlogs
   Bug tracker
   Locale browser
 

 Categories

   o Audio (330)
   o Datatype (47)
   o Demo (186)
   o Development (541)
   o Document (21)
   o Driver (89)
   o Emulation (142)
   o Game (874)
   o Graphics (469)
   o Library (102)
   o Network (205)
   o Office (56)
   o Utility (825)
   o Video (62)

Total files: 3949

Full index file
Recent index file

 Links

  Amigans.net
  OpenAmiga
  Aminet
  IntuitionBase


Support the site


 File comments for:  Audio » Play » amigaamp3.lha

AmigaAMP3

Description: Multi format audio player with GUI
Download: amigaamp3.lha
Version: 3.25
Date: 21 Aug 2019
Category: audio/play
FileID: 10998
RSS Feed url: http://os4depot.net/modules/comments/rssfeed.php?file=audio/play/amigaamp3.lha

[Back to readme page]   [Add Comment]   [Refresh page]

Comment by: Thematic (88.114.191.122)At: 28 Aug 2019, 20:59File version: 3.25
Regarding HTTP(S), all you need to do is have a file with just the URL, linefeed optional, and load that as a playlist. Works with Wikimedia Ogg Vorbis.
 
 
Comment by: Raziel (188.193.107.79)At: 26 Aug 2019, 21:28File version: 3.25
@TomSoniq

Awesome, thanks a lot

Request:
Would it be feasable to add a http: handler, so that http: addresses that hold music files can be directly passed to and played back by AmigaAmp?
 
 
Comment by: TomSoniq (91.17.88.172)At: 26 Aug 2019, 20:24File version: 3.25
Mmh, I've implemented a very evil bug: A race condition. :-O
Happens only sometimes. And whether it happens or not depends on a lot of things.
Very hard to track!
But hopefully fixed now! Some more testing and then there'll be a 3.26 :)
 
 
Comment by: TomSoniq (91.17.88.172)At: 26 Aug 2019, 19:16File version: 3.25
Found something!
Somehow I proke the code of internally passing the name of the play list to open.
Oops!
I'll debug and fix it. :)
 
 
Comment by: Raziel (188.193.107.79)At: 24 Aug 2019, 19:11File version: 3.25
@TomSoniq

I'm afraid you definitely broke something in the .pls loading code :-)

1) If i try to load a .pls file with the "Open" button in main window, nothing happens
2) If i try to load a .pls file with the "Open..." command from PD menu, nothing happens
3) If i try to load a .pls file by dragging and dropping it over the main window, nothing happens
4) If i try to load a .pls file by dragging and dropping it over the playlist window, IT WILL WORK

And that is the only way to make my .pls files work with AmigAmp 3.25 (worked with all of the above with the previous version.
 
 
Comment by: Alessandro Bacchia (93.41.3.7)At: 23 Aug 2019, 13:19File version: 3.25
Hello again.
Small update, then I uploaded several pls files, even a few m3u, but nothing to do doesn't load them at all. Not only, but if I use amigaamp from ram disk IT WORKS !!! Nothing in both cases from the 68k side. This for me is inexplicable, patience I will continue to use the old version until the new one in the future. Thanks for the attention.
 
 
Comment by: TomSoniq (91.17.88.172)At: 22 Aug 2019, 18:54File version: 3.25
Oh, that's stange. Maybe I've broken something. My pls file for testing still works. Can you please point me to yours that doesn't work? I'll fix it! :)
Thanks, Thomas
 
 
Comment by: Alessandro Bacchia (93.41.3.7)At: 22 Aug 2019, 12:20File version: 3.25
I downloaded and tried both ppc and 68k versions, unfortunately when I try to upload a pls file to a streaming radio, a laconic "no file" appears without playing anything. Yet in version 3.24 it loads and reproduces it without any problem. My two amigas are: Sam440 and Amiga1200 with blizzard 1230 equipped with Mas Player Pro. Maybe I'm wrong?
 
 
Comment by: dzanino (188.167.253.201)At: 21 Aug 2019, 17:58File version: 3.25
This version is my full replacement for Eagleplayer I use on Classic Amiga
it plays mod., .xm, .s3m etc compressed by xpk and other I used in the past a lot
And had a huge archive of mods :|
thank you Thomas!!!
 
 
Comment by: TomSoniq (87.149.66.23)At: 23 Jul 2019, 12:45File version: 3.24
Progress:
"Files not closed properly" bug identified and fixed.
Metadata / tags window now properly cleared if you load a file without metadata. It doesn't display the data of the previously opened file any more.
Will post a new release soon. :)
 
 
Comment by: TomSoniq (89.182.224.229)At: 21 Jul 2019, 09:04File version: 3.24
Hi!
For one day I posted a debug version on my site by mistake. Someone took it and uploaded it here. That's not his fault. Everything that's on my site may be freely copied anywhere else.
About the flac metadata issue: Guess I've broken it during code cleanup and not noticed it. I'll fix it asap. Promised. :)
 
 
Comment by: kas1e (80.64.105.7)At: 18 Jul 2019, 16:49File version: 3.24
@Thematic
You better wrote bug reports to Tom directly (his mail in readme somewhere , and on site), as it we who upload it on os4depot, and he probabaly didn't read those comments.
 
 
Comment by: Thematic (88.114.191.122)At: 18 Jul 2019, 15:49File version: 3.24
Having done some poking around, I notice I cannot delete my audio files that were opened, after I close the player. Not closed properly?
 
 
Comment by: Thematic (88.114.191.122)At: 18 Jul 2019, 15:30File version: 3.24
Apologies. My previous information was inaccurate. Here's a procedure that should reproduce the effect: Add to a blank playlist a file that has artist & title information. Add either an Ogg Vorbis or FLAC file that does not have the metadata. No need to open the first file for playback, go straight to the "unknown" file. (> flac -o ok.flac something.wav)
 
 
Comment by: Raziel (188.192.124.16)At: 17 Jul 2019, 13:12File version: 3.24
@kas1e

Ok, must have missed it.
 
 
Comment by: kas1e (80.64.105.7)At: 17 Jul 2019, 08:08File version: 3.24
@Raziel
No,it is not beta version. I reuploaded on fixed one right on next day when Tom release fixed version. I.e. version from site are the same as from there at moment.
 
 
Comment by: Raziel (188.192.124.16)At: 17 Jul 2019, 07:30File version: 3.24
@Thematic

Nearly my entire music collection is FLAC and i've never seen such behaviour.

Please redownload the app from the original site here: http://www.amigaamp.de/download.shtml
The version on OS4Depot is a beta version with probably still bugs in place (wasn't uploaded here by Tom).

Then try with different FLAC pieces and see if the error goes away.
 
 
Comment by: Thematic (88.114.191.122)At: 16 Jul 2019, 12:09File version: 3.24
FLAC tag reading (file beginning with fLaC) is not working. The program displays the information of the previous file. The correct duration is shown and used. It actually does work for the case of adding a file or directory to the playlist, but upon starting playback it goes as described.
 
 
Comment by: Raziel (188.193.158.57)At: 17 Jun 2019, 19:34File version: 3.24
Get the version from the mentioned Homepage

"uploader" uploaded the debug version
 
 
Comment by: Petrol (90.103.225.101)At: 16 Jun 2019, 20:42File version: 3.24
List of available skins is limited in the menu.
 
 
Comment by: K-L (87.231.115.144)At: 16 Jun 2019, 11:12File version: 3.24
I think this is the debug version : a window popups regarding freevec when opening a file.
 
 
Comment by: Thematic (88.114.191.122)At: 05 Dec 2018, 17:17File version: 3.23
(In skinned operation)
If you iconify the program when the playlist window is open, then upon uniconify when you click an entry, it won't select the right one if there was an offset when you iconified it. In other words the topmost visible entry was not the first entry in the playlist. If you encounter this but want to select something further down, click the scroll bar, that way you'll at least get in the right ballpark.
 
 
Comment by: HKvalhe (80.213.142.128)At: 02 Dec 2018, 21:41File version: 3.16
Nice to have a new update of this excellent MP3 player, but it's actually version 3.23, NOT 3.16. A little error on that version revision here. Please correct it with 3.23. Otherwise, always great to have a new update showing off the true capabilities of this player.
 
 
Comment by: Thematic (91.159.148.92)At: 25 Nov 2016, 13:56File version: 3.16
Correction: the FLAC behaves the same as Ogg, it has uncompressed or PCM size.
 
 
Comment by: Thematic (91.159.148.92)At: 25 Nov 2016, 13:54File version: 3.16
An inconsistency and by no means a real problem but the info box, first row, lists file or compressed stream sizes for mp3 and flac, but for Ogg Vorbis it shows the size uncompressed.
 
 
Comment by: HKvalhe (80.213.142.202)At: 27 Apr 2014, 12:04File version: 3.14
Just a small note. On version 3.15 of AmigaAMP, there seems to be a lack of the important MP3 tag function. One example, when running the next song after the first, the display of the title of the songs seem to be mixed into each other, instead of displaying the right title for each song without interferring with the other songs.

Please bring back the MP3 tag feature again. It's strongly needed. Other than that, 3.15 is definitely an improvement. Keep it up :)
 
 
Comment by: trixie (82.40.52.129)At: 10 Feb 2014, 00:05File version: 3.14
I support what imagodespira says: don't hold the screen locked. This is how modern Amiga software should behave:

- LockPubScreen().
- Open your program window and UnlockPubScreen() as soon as all program visuals are initialized and/or displayed. (An opened window will prevent the screen from closing = no need to hold the lock.)
- When the program becomes iconified, drop any screen references/pointers you may be holding.
- Upon receiving an uniconify command, LockPubScreen() again, reopen window, then UnlockPubScreen().
 
 
Comment by: imagodespira (94.222.57.163)At: 09 Feb 2014, 09:27File version: 3.14
I have two things i like to have:

1. Iconify Gadget in the Titlebar (Reaction Theme), currently it works only with Shortcut
2. It seems the program locks the screen (also if iconified). It would be nice if it is unlocked, i build Themes and on every change in GUI.prefs i have to close AmigaAmp, in Tunenet it works fine if iconified.

Test: Change a theme while playing music and iconified... workbench can not be closed.

Thanks, also for making this software. Runs well and would be nice if it will be my only player if the screen is free if i build themes ;)
 
 
Comment by: marko (83.183.213.4)At: 06 Feb 2014, 05:00File version: 3.14
@Thomas Wenzel

Please add AmiUpdate functionality :)
 
 
Comment by: zzd10h (80.119.216.201)At: 03 Nov 2013, 13:53File version: 3.8
If you play this playlist from aTunes, iconification works well ;)

"PlayList window / Load / Play"
 
 
Comment by: gtmooya (89.168.188.220)At: 03 Nov 2013, 13:20File version: 3.8
@zzd10h

Ok, thanks. Was a playlist I made with aTunes as it happens. ;-)
 
 
Comment by: zzd10h (80.119.216.201)At: 03 Nov 2013, 13:18File version: 3.8
Yes, you are right.
iconification works only if started by "WBRUN APPDIR:amigaamp3"

I have to do that in aTunes to avoid this problem when calling AAmp.

AAMp author was notified of this problem
http://www.amigaamp.de/board/viewtopic.php?t=241


 
 
Comment by: gtmooya (89.168.188.220)At: 03 Nov 2013, 13:11File version: 3.8
Possible bug when starting AmigaAMP from APPDIR, i.e. by double clicking an m3u playlist whose deficon points to to APPDIR:AmigaAMP3.

When iconifying AmigaAMP after starting this way there is no icon on Workbench, however works as expected if AmigaAMP is is run from its own icon or AmiDock.
 
 
Comment by: gtmooya (89.168.188.220)At: 03 Nov 2013, 13:11File version: 3.8
Possible bug when starting AmigaAMP from APPDIR, i.e. by double clicking an m3u playlist whose deficon points to to APPDIR:AmigaAMP3.

When iconifying AmigaAMP after starting this way there is no icon on Workbench, however works as expected if AmigaAMP is is run from its own icon or AmiDock.
 
 
Comment by: Thematic (88.113.183.93)At: 13 Feb 2013, 22:51File version: 3.5
Streaming audio displays the wrong duration, the timer runs at half speed only. Not sure if previous versions did this.
 
 
Comment by: Massimiliano Scarano (93.42.86.220)At: 13 Feb 2013, 09:25File version: 3.5
Really appreciated XM and S3M support, awesome work as usual, thanks.
 
 
Comment by: SCabit (70.193.194.162)At: 15 Jan 2013, 18:35File version: 3.5
It looks like this version (3.5) now works fine with other audio programs running that use AHI. Previously if something was using the AHI default channels, AmigaAMP would give an error on startup saying it could not allocate channels. That is now fixed. Good work!
 
 
Comment by: Tuxedo (95.246.189.86)At: 17 Oct 2011, 20:21File version: 3.3
Any new version on the horizon?

:D

Good WORK!
 
 
Comment by: TSK (84.248.40.19)At: 16 Aug 2011, 14:16File version: 3.3
Especially mod & med playing.
 
 
Comment by: TSK (84.248.40.19)At: 16 Aug 2011, 14:14File version: 3.3
It would be really great if AmigaAmp3 could support Tunenet plugins !
 
 
Comment by: redfox (66.222.154.116)At: 11 Jul 2011, 19:07File version: 3.2
Quite by accident, I noticed that AmigaAMP v3.2 stops playing and vanishes from screen after I issue a netshutdown command. I was playing an mp3 file from my RAMDISK at the time. Also happens if playing an mp3 file from hard disk.

Also happens with AmigaAMP v3.1 and v3.0.

AmigaAMP v2.21 is not affected by netshutdown or net startup while playing mp3 files form RAMDISK or hard drive.

This is not a show stopper, just an unexpected thing.

---
redfox
 
 
Comment by: Thematic (85.156.234.245)At: 01 May 2011, 19:13File version: 3.2
YesCop: The playlist is indeed without duration information. See "List scan method" in prefs, it's been in since old times.

If you move the window quickly it won't pause with playback. ;)
 
 
Comment by: shadowsun (10.20.211.11)At: 21 Apr 2011, 06:20File version: 3.2
- We can change it with prefs, but by default, ogg (and some others ?) are not in ASL pattern

- When you move program window when playing music, music is stopped
 
 
Comment by: shadowsun (10.20.211.11)At: 21 Apr 2011, 06:05File version: 3.2
- We can change it with prefs, but by default, ogg (and some others ?) are not in ASL pattern

- When you move program window when playing music, music is stopped
 
 
Comment by: YesCop (77.192.152.187)At: 20 Apr 2011, 21:40File version: 3.2
Hi,
I have an error for ages in Amigaamp. Idem in the last version.
When I load a list of my mp3 files and begin playing them, the time is unknown and equal to zero.
If I directly load the file, the time works.
The list I used is a simple text containing the paths to the files.

Thanks fort AmigaAmp.
 
 
Comment by: samo79 (188.152.138.216)At: 20 Apr 2011, 08:57File version: 3.2
Yep you are right, version string doesn't work anymore :-/
 
 
Comment by: ktadd (67.188.6.182)At: 20 Apr 2011, 06:13File version: 3.2
Thanks for the update! Ogg support is nice to have.

Anyone else notice the version string doesn't appear to be present in this version?
It worked in v3.1.
 
 
Comment by: Tuxedo (79.9.189.143)At: 19 Apr 2011, 21:36File version: 3.2
Hi!
Also supporting newest IDTAGs was nice! Thank you!
Keep up great work!
 
 
Comment by: Lio (95.171.139.85)At: 19 Apr 2011, 16:45File version: 3.2
ogg and flac supported, miam miam !
thx a lot !
 
 
Comment by: Thematic (85.156.234.245)At: 19 Apr 2011, 15:53File version: 3.2
Hooray for free formats!
 
 
Comment by: Tuxedo (188.152.131.0)At: 14 Mar 2011, 12:32File version: 3.0
Why not suport both idv1 and v2.x?
So you can read all the infos no? :)
 
 
Comment by: TomSoniq (217.91.9.206)At: 14 Mar 2011, 10:45File version: 3.0
Low buffer sizes just mean that playback is easier interrupted by high system load.

Last time I had a look at ID3V2 I couldn't find any example source code but just ready made link libraries for some Windows and Linux compilers only. And every time a new version of this tag system comes out the old code can't read the new tags any more. So this is not a true expandable format but one that's completely replaced with new incompatible stuff from time to time. I'm sick of it, sorry.
 
 
Comment by: Tuxedo (188.152.131.0)At: 11 Mar 2011, 22:24File version: 3.0
Hi and thanks for the reply!

1 - OK I'll try it! Any problem can be caused to decreasing the buffer low and low?

2 - hope that you can solve that soon :)

3 - GOOD!

4 - nice :)

5 - well...the support of only IDv1 tag was a bit ugly since it dont contain JPop identifier and also the nice embedded image extension was really udefull and really nice to see :)
Also nice was to have the song lyric from the IDV2.x ...
I found that wikipedia ID specs:

http://en.wikipedia.org/wiki/ID3

Dont seems to bad...

Really you dont think to support that in future? Maybe supporting IDv1 and v2 at same time...

Sorry to bother but was really nice and usefull to see the album cover and lyrics while listening the song imho...
You can try to sinfg it also if you dont know the text and/or wasnt your native language...

Good WORK!
 
 
Comment by: TomSoniq (217.91.9.206)At: 11 Mar 2011, 10:04File version: 3.0
1. Sorry, volume, balance and also the EQ work on playback buffers. The larger the playback buffer the longer it'll take until you hear the effect. This can't be avoided. The only workaround is to set small playback buffers like 1/2 second or even down to 1/5 second.

2. The window dragging is a bit ugly, that's right. But I haven't figured out a way yet to drag several windows at once under OS4. The old classic AmigaOS trick doesn't work properly any more and produces the effect you're seeing.

3. Ogg is planned for the next release.

4. Oops, sorry, I forgot to re-implement the EQ presets. Now scheduled for next release as well.

5. Info windows will be changed from GadTools to ReAction soon. But I probably won't add newer ID2V2 support. It's a crappy and very poorly documented format and it's not even backward compatible.
 
 
Comment by: Tuxedo (188.152.134.172)At: 10 Mar 2011, 22:44File version: 3.0
Nice but...

1 - the volume and balance sliders moves doesnt react immediately(for exampleif I low the volume it will lowed onyl after a short time...

2 - If I drag the main window the playlist and eq window wasnt dragger toghtert that window but only after the main window was positioned

3 - No ogg support..planned forthe future?

4 - no eq presets available

5 - ugly about window and IDTag window(taht supports only and old IDTag version...

Sorry for that list but I like really much AmigaAMP and like to can get it working as my base audio player and at that point that wasnt possible unfortunately...

GOOD WORK!

Simone.
 
 

Copyright © 2004-2019 by Björn Hagström All Rights Reserved